STORAGEGROUP al introducir una cinta en la ATL

Manejo de almacenamiento tanto en discos como en medios magneticos, DFSMSxxx (todo lo relacionado con el SMS).
Responder
Avatar de Usuario
pcadan
Usuario avanzado
Usuario avanzado
Mensajes: 31
Registrado: 15 Nov 2005, 09:09
País: España
Ciudad: Madrid
Ocupación: System Programmer

STORAGEGROUP al introducir una cinta en la ATL

Mensaje por pcadan » 30 Sep 2011, 09:19

Hola, hace tiempo que tengo un problema y no he dado con la solución :bronca: , a ver si alguien me puede ayudar.
Se trata del STORAGEGROUP que se asigna a una cinta PRIVATE al ser introducida en una librería automática de cintas (ATL)
En mi caso, el STORAGEGROUP asignado es nulo (creo que es el defecto) y me genera problemas posteriormente en el procesado de dichas cintas, por lo que tengo que cambiarlo manualmente a través de los paneles de ISMF.

Me gustaría saber cuál es la manera de que se asigne durante la entrada de la cinta un STORAGEGROUP para las cintas PRIVATE.
En mi caso no utilizo RMM, sino que utilizo CA-1

Muchas gracias de antemano y un saludo.
Pedro.
Pedro Carlos Adán

Avatar de Usuario
Vicente
Colaborador avanzado
Colaborador avanzado
Mensajes: 542
Registrado: 21 Jul 2011, 04:52
País: España
Ciudad: Malaga
Ocupación: Técnico en Sistemas

Re: STORAGEGROUP al introducir una cinta en la ATL

Mensaje por Vicente » 30 Sep 2011, 10:13

Hola pcadan:
Supongo que no has encontrado la solución por la opcion 10.3 de ISMF.
Si es así, yo me plantearía revisar el código de la rutina de selección automática de storagegroup activa en tu instalación (opción 7 del menu de ISMF).
Saludos
Varios días probando, equivocandote y volviendo a probar
pueden ahorrarte quince minutos de lectura de un manual.

Avatar de Usuario
pcadan
Usuario avanzado
Usuario avanzado
Mensajes: 31
Registrado: 15 Nov 2005, 09:09
País: España
Ciudad: Madrid
Ocupación: System Programmer

Re: STORAGEGROUP al introducir una cinta en la ATL

Mensaje por pcadan » 04 Nov 2011, 07:49

Hola! no he conseguido avanzar con este tema, no soy capaz de que al introducir una cinta en el robot (introducir, no solicitar montaje) se le asigne un storagegroup y se queda con dicho valor en blanco.
En la opción 10.3 del ISMF he visto solamente cómo asignar una dataclas y en cuanto a las rutinas... ¿se disparan cuando entra una cinta? tengo mis dudas ya que si se dispararan, debería de asignarse el storagegroup a partir de la dataclas de entrada.
Lo único que he encontrado es modificar una exit (la CBRUXEPL) que es la que tiene una lista de parámetros que utiliza la CBRUXENT (entre ellos el storagegroup)

Me parece un poco raro el tener que modificar la exit para lo que quiero hacer, seguro que hay una manera más fácil pero... no doy con ella.

¿alguna idea?

Muchas gracias.
Pedro Carlos Adán

Avatar de Usuario
Vicente
Colaborador avanzado
Colaborador avanzado
Mensajes: 542
Registrado: 21 Jul 2011, 04:52
País: España
Ciudad: Malaga
Ocupación: Técnico en Sistemas

Re: STORAGEGROUP al introducir una cinta en la ATL

Mensaje por Vicente » 07 Nov 2011, 05:25

Hola pcadan:
Hasta donde yo se, las rutinas ACS se disparan en el momento de crear un fichero (en el OPEN).
Yo tengo una librería de cintas de StorageTek (después de SUN Microsystems y ahora de Oracle) y no he encontrado en el software de la librería la función que necesitas, ni siquiera con una exit.
Si lo que quieres es hacer grupos de cintas libres para después utilizarlas selectivamente, ¿Has pensado en
la funcionalidad de POOLes que te proporcione tu software de la librería o el software de gestión y control de ficheros en cintas?
Siento no poder ayudar más.
Un saludo
Varios días probando, equivocandote y volviendo a probar
pueden ahorrarte quince minutos de lectura de un manual.

Responder