Componente perdido de un cluster

Manejo de almacenamiento tanto en discos como en medios magneticos, DFSMSxxx (todo lo relacionado con el SMS).
Responder
admin
Administrador
Administrador
Mensajes: 22
Registrado: 12 Oct 2003, 15:58
País: Argentina
Ciudad: Zárate
Ocupación: Otra

Componente perdido de un cluster

Mensaje por admin » 10 Dic 2003, 21:19

:?: Tengo varios archivos vsam en disco que no estan asociados a ningun cluster. Me dijeron que son de cluster de un catalogo que ya no existe, pero que no fue borrado, sino desconectado.

¿COMO LOS BORRO ?

Agradezco si alguien me ayuda.

Original posteado por NN. (Recuperado de backup por fallas del foro)
Última edición por admin el 10 Dic 2003, 21:54, editado 1 vez en total.

admin
Administrador
Administrador
Mensajes: 22
Registrado: 12 Oct 2003, 15:58
País: Argentina
Ciudad: Zárate
Ocupación: Otra

Mensaje por admin » 10 Dic 2003, 21:22

He probado hacerlo con ADRDSSU y otros utilitarios y no fue posible, lo que no quiere decir que exista por ahì algùn truco para lograrlo, lo que si se puede hacer es lo siguiente:
Migrar todos los demas archivos catalogados de ese disco \"A\" a otro disco \"B\" , luego inicialar el disco \"A\" donde estan estos VSAM sin catálogo , al inicilarlo se borra TODO.
Luego reponer a este disco \"A\" los archivos catalogados migrados previamente al \"B\" .
El tema es que esta tarea es prerrogativa del admimnistrados de espacio en disco, que es justo mi tarea, de modo una posibilidad es mandar un coreo al administrador para que con los recaudos del caso efectúe esta operatoria, de todos modos voy a investigar para ver si se puede encontrar la forma de hacerlo sin inicilar.
Ernesto

Original posteado por Ernesto (recuperado de backup por fallas del foro)
Última edición por admin el 10 Dic 2003, 21:55, editado 2 veces en total.

admin
Administrador
Administrador
Mensajes: 22
Registrado: 12 Oct 2003, 15:58
País: Argentina
Ciudad: Zárate
Ocupación: Otra

Mensaje por admin » 10 Dic 2003, 21:24

el IDCAMS con DELETE VVR normalmente da resultado con este problema.
Ejecutalo de la sig. forma :

//IDCAMS EXEC PGM=IDCAMS
//IN1 DD DSN=SYS1.VVDS.VDDDDDD,DISP=SHR
//SYSPRINT DD SYSOUT=*
//SYSIN DD *
DELETE \'XXXXXXXX.XXXXXXXX.DATA\' VVR FILE(IN1)
DELETE \'XXXXXXXX.XXXXXXXX.INDEX\' VVR FILE(IN1)
//

Previo a esto, si queres, podes correr un DIAGNOSE sobre el VVDS para que te diga los errores que tiene, pero es solo informativo.

En caso de no funcionar, avisa y vemos otras alternativas.

Daniel

Original posteado por Daniel Arona (recuperado de backup por fallas del foro)
Última edición por admin el 10 Dic 2003, 21:56, editado 2 veces en total.

admin
Administrador
Administrador
Mensajes: 22
Registrado: 12 Oct 2003, 15:58
País: Argentina
Ciudad: Zárate
Ocupación: Otra

Mensaje por admin » 10 Dic 2003, 21:26

Muchas gracias por sus respuestas, pero use la de Daniel que me pareció mas sencilla y funcionó correctamente.

Original posteado por NN. (Recuperado de backup por fallas del foro)

Responder